Resolved
The service is still healthy and this incident has been resolved.
Monitoring
The affected server is back online. We are monitoring the health of the coordination service.
Identified
We are aware of reports of the coordination service responding slowly and affecting some users. The cause has been quickly identified, and we are working on a fix.