·
This incident has been resolved.
Resolved
Monitoring
A fix has been deployed and we are monitoring for any further problems.
Investigating
We are aware of slow and unresponsive logins for some users. We are investigating the cause.