Google Sync User Deletions
Resolved·Degraded performance

A mitigation has been applied. If you are seeing erroneous user deletion events please reach out to our support team here: https://tailscale.com/contact/support.

Tue, Jan 20, 2026, 01:52 AM
(1 day ago)
·
Affected components
Coordination server
Updates

Resolved

A mitigation has been applied. If you are seeing erroneous user deletion events please reach out to our support team here: https://tailscale.com/contact/support.

Tue, Jan 20, 2026, 01:52 AM

Identified

The team is working on implementing a possible mitigation for the user deletion behavior we are seeing. Currently, the issue looks to be caused by inconsistencies in responses from Google's API endpoint.

Tue, Jan 20, 2026, 12:51 AM(1 hour earlier)

Investigating

Our monitoring has detected an increase in user deletions from Google Sync and we are investigating further. Initial investigations indicate that deleted users will be re-created on the next sync.

Mon, Jan 19, 2026, 10:43 PM(2 hours earlier)