Resolved
This issue has been resolved.
Monitoring
We are seeing that the service is healthy, and are monitoring for any further issues.
Identified
We are implementing a potential fix for this problem and monitoring the results.
Investigating
We are aware of reports of the coordination server responding slowly, affecting some users, and we are investigating the scope of the issue.