Partial Outage: Control Plane (Authentication & Admin)
Resolved·Full outage

Control-plane functionality has returned to normal and remains stable. The service is healthy and we are continuing to monitor service health.

Tue, Oct 21, 2025, 02:30 AM
(15 hours ago)
·
Affected components
Admin console (login.tailscale.com)
API (api.tailscale.com)
Coordination server
Updates

Resolved

Control-plane functionality has returned to normal and remains stable. The service is healthy and we are continuing to monitor service health.

Tue, Oct 21, 2025, 02:30 AM

Monitoring

Affected systems are operational; however, additional remediation is necessary. We are monitoring to ensure that systems remain online.

Tue, Oct 21, 2025, 12:39 AM(1 hour earlier)

Monitoring

We have identified the issue, and have restarted affected services after applying a fix. We are now monitoring to ensure our systems are healthy.

Mon, Oct 20, 2025, 11:59 PM(39 minutes earlier)

Investigating

A subset of customers are seeing failures/timeouts for login, device auth, and control-plane updates (ACLs, DNS, routes, device changes). Device-to-device traffic for already-connected peers generally continues. It is advised not to remove any machines from your tailnet at this time, as you may not be able to reauthenticate them.

Mon, Oct 20, 2025, 10:51 PM(1 hour earlier)