·
This incident has been resolved.
Resolved
Identified
We have identified the problem and are rolling out a fix.
Investigating
We are aware of unresponsive logins for some users. We are investigating the cause.