Resolved
This incident has been resolved.
Monitoring
The admin console and pkgs.tailscale.com are now both operational. We are monitoring the situation for any further degradation in service.
Identified
We have identified that Amazon Cloudfront is experiencing issues: https://health.aws.amazon.com/health/status, and is the cause of the 504 errors seen on the admin console and pkgs.tailscale.com.
Our teams have rolled out a fix for the admin console.
pkgs.tailscale.com is still unavailable at this time.
Investigating
We are aware of reports of the admin console and pkgs.tailscale.com not being available for users, and we are investigating the scope of the issue.