Resolved
This incident has been resolved.
Monitoring
We have deployed a fix for the issue causing the billing wizard to unexpectedly refresh during plan upgrades. We are now monitoring to confirm the issue is fully resolved.
Identified
We have identified the cause of the issue affecting plan upgrades for some users in the Billing section of the admin console and are working on a fix
Investigating
We are investigating an issue preventing some users from upgrading their plans in the Billing section of the admin console. The billing wizard may unexpectedly refresh after billing details are entered, preventing the upgrade from completing