Resolved
This issue has now been resolved.
Monitoring
A fix for this has been implemented and we are monitoring.
Identified
We are investigating a problem causing coordination server errors for some users, including slow performance of the admin console and API.