Mullvad registration failures
Resolved·Degraded performance

The service is still healthy and this incident has been resolved.

Tue, Nov 25, 2025, 10:46 AM
(1 month ago)
·
Affected components
Mullvad exit nodes
Updates

Resolved

The service is still healthy and this incident has been resolved.

Tue, Nov 25, 2025, 10:46 AM

Monitoring

We are seeing that the service has recovered and that registrations are succeeding again. We are monitoring for any further issues.

Tue, Nov 25, 2025, 09:28 AM(1 hour earlier)

Identified

The Mullvad team have identified the issue and are working on a fix.

Tue, Nov 25, 2025, 08:40 AM(48 minutes earlier)

Investigating

We are investigating an issue which is causing new machine registrations with Mullvad to fail. Existing machines registered to Mullvad do not appear to be impacted and are continuing to work.

Tue, Nov 25, 2025, 08:28 AM(12 minutes earlier)