Resolved
We are not seeing any further issues, the incident is resolved.
Monitoring
We are no longer seeing slow logins and will continue to monitor.
Investigating
We are aware of slow and unresponsive logins for some users. We are investigating and have already taken actions to mitigate.