Slow admin console
Resolved·Degraded performance

We have confirmed that the recovery was successful, and this incident is resolved.

Fri, Oct 31, 2025, 10:58 AM
(1 week ago)
·
Affected components
Admin console (login.tailscale.com)
Updates

Resolved

We have confirmed that the recovery was successful, and this incident is resolved.

Fri, Oct 31, 2025, 10:58 AM

Monitoring

The cause of the slowness has been fixed and we are monitoring recovery.

Fri, Oct 31, 2025, 10:46 AM(12 minutes earlier)

Identified

We are aware of an issue causing the admin console to load & respond slowly, and we are remediating it.

Fri, Oct 31, 2025, 10:43 AM