Devices API change impact
Resolved·Degraded performance

We have finished rolling out the change to restore the lastSeen field on devices which are connected to Tailscale's control server, and the impact has been mitigated.

Fri, Oct 10, 2025, 02:44 PM
(5 days ago)
·
Affected components
API (api.tailscale.com)
Updates

Resolved

We have finished rolling out the change to restore the lastSeen field on devices which are connected to Tailscale's control server, and the impact has been mitigated.

Fri, Oct 10, 2025, 02:44 PM

Identified

We are rolling out a change to restore the lastSeen field on devices which are connected to Tailscale's control server to mitigate any further impact.

Fri, Oct 10, 2025, 01:26 PM(1 hour earlier)

Investigating

A change to the lastSeen field is causing unexpected negative impact to some workloads, we are investigating how we can mitigate this problem and will update once we have more to share.

Fri, Oct 10, 2025, 11:59 AM(1 hour earlier)