Mullvad registration failures
Resolved·Partial outage

We are not seeing any further issues, this incident is resolved.

Tue, Sep 30, 2025, 12:35 PM
(2 weeks ago)
·
Affected components
Mullvad exit nodes
Updates

Resolved

We are not seeing any further issues, this incident is resolved.

Tue, Sep 30, 2025, 12:35 PM

Monitoring

The Mullvad team have pushed a fix and we are seeing registration successes again. We are monitoring for any further issues.

Tue, Sep 30, 2025, 12:06 PM(28 minutes earlier)

Investigating

We are investigating an issue which is causing new machine registrations with Mullvad to fail. Existing machines registered to Mullvad do not appear to be impacted and are continuing to work. The https://mullvad.net/en/servers page mentions there are errors with their DAITA servers, and we are investigating whether this is related to the errors we are seeing.

Tue, Sep 30, 2025, 11:59 AM