Resolved
DNS records have been updated and connectivity should be restored for affected clients.
Monitoring
We have reduced the number of DNS records for the affected hostnames to match what they were before some changes made last week. This should mitigate the impact and we are monitoring for reports of further problems.
Identified
Some people report issues resolving login.tailscale.com, controlplane.tailscale.com and api.tailscale.com, causing issues with the admin panel, device login prompts, contacting the coordination server, and accessing our API server.
We are still investigating, but it appears that the problem affects systems that are unable to handle large DNS responses.