Elevated configuration propagation latency
Resolved

After further improvements to control sharding and subsequent monitoring, we are no longer observing increases in node propagation latency, and consider this issue resolved.

Thu, May 29, 2025, 08:51 PM
(3 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

After further improvements to control sharding and subsequent monitoring, we are no longer observing increases in node propagation latency, and consider this issue resolved.

Thu, May 29, 2025, 08:51 PM

Monitoring

Improvements in latency have been made, but our team will continue to monitor before considering this fully resolved.

Mon, May 19, 2025, 02:26 PM(1 week earlier)

Investigating

We are investigating increased propagation latency of configuration updates that impacts some tailnets. Changes to tailnet membership (e.g. new nodes joining) are propagated with a delay of up to 1 minute.

Thu, May 15, 2025, 05:27 PM(3 days earlier)
Powered by